File Size


  • Trying to make a wedding gift and after designing it and getting the file set up in Sheet Cam, I save it to my thumbdrive and it winds up being 88KB in size.  When I try to import it into the ArcDroid, I receive an error saying the file is too big and it only imports part of the file.  What size file can we import?  Am I missing something?  Little help would be appriciated as I need the gift next weekend.

     

    Paul



  • We are also having the same problem. Is there a file size limit or a line limit with the gcode. Also is there any plans for an upgrade to be able to increase the limit? I can do a simple 10kb gcode but if I try and simple letter sign at 61kb it freezes when I try to updoad to the Arcdroid.


  • I actually was able to design and cut an address sign for my mother in law that was 44kb


  • Hey guys  it's not actually about absolute file size  it has more to do with the number of lines of code.  We can take about 3500 lines which should pretty much fill the screen!

    If you have a sign or something with a lot of Curves the software breaks those curves into a lot of tiny little straight lines...each gets a line of g-code this make the file really long.

    For obvious reason the AD has limited memory onboard so it can only process so many.  We are actually working on optimizing it a bit and just having the machine only display the number of cut lines it can comfortably decompress but run the whole program regardless of size... So look for an update coming down the pipe.

    In Fusion the was to reduce file size is change the "tolerance" to something more realistic (default is like 0.0004"  which is nuts.  So it unnecessarily bloats the file .

    In SheetCam I think it has to do with import tolerance of the dxf  I can't remember the exact method for changing this...but I'll take a look when I get back to the office and Update shortly if I can.

    Bottom line...les nodes on your curves = less lines of code = easier for the AD to process.

    cheers
    AM


  • Okay  I had quick look....yep it's definitely the DXF import tolerance on SheetCam
    Set as default to the same really small 0.01mm as Fusion... easy fix  just up the tolerance to something less miniscule and it will reduce your output file size a LOT

    Go to Options -> Application Options -> Drawing Import and change the values there... even just doubling the tolerance will reduce you file size almost 4x

     

    Cheers
    AM

     


  • Thanks Andrew...You da man!!


  • So I just went into SheetCam and checked the Import Link Tolerance.  Hopefully that is what I am supposed to change.  It's set to 0.0004 inches which is about 0.01mm, correct?  Does this mean I am already as small as I can go?


  • Hey Paul

    Yeah thats WAY too small you want a bigger number...ther is no Plasma system on the planet that wil cut a lin 0.0004" long.

    I recomend 10X that size 0.004"  should be fine.


    Cheers

    Am


  • Thanks for the help, we are working on learning with FreeCAD and wanted to use there Path workbench to produce the Gcode. I was able to greatly reduce the size of the file with increasing the tolerance. Now im just working on figuring out a post processor that works for Arcdroid using FreeCAD. I will update you all if we find a way to.


Please login to reply this topic!